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Introduction 

Welcome! This guide will take you step-by-step through the creation of a small 1v1 map 
entitled Summer Duel. Before you continue reading, please ensure you have the following tools: 

• The Supreme Commander map editor, downloadable from _____ 

• Image-editing software capable of editing 16-bit images. Photoshop CS and Paint 
Shop Pro X are the main contenders. (Newer versions work just as well.) This 
isn’t strictly a requirement, but it will make your life much easier. Both pieces of 
software are available as a 30-day free trial if you don’t currently own them. 

If you’ve already taken a look at the Supreme Commander map editor, you’re probably a 
little confused. At first glance it doesn’t seem like there is a whole lot there. You’ve also 
probably noticed that there isn’t quite as much polish as Supreme Commander itself. This is 
because the tool was first built for internal use. Don’t let that get you down! This is the same 
editor that GPG uses at their studio. We are very lucky to have access to it. Everything you need 
to create rich maps like the ones that shipped with the game can be found in the editor, once you 
get used to it. 

A word of caution: a good map takes many, many hours to complete. A lot more goes 
into maps than throwing up a heightmap and slapping down some textures. Doing those things is 
easy enough, but doing them in an interesting and gameplay promoting way is very difficult. If 
you have the patience, however, playing on a map you designed yourself can be a rewarding 
experience. 

 
Getting Started 

 Go ahead and start the map editor. You will be greeted by a familiar splash screen. The 
editor integrates directly with the game engine, and it puts it to some pretty cool uses. The splash 
screen will disappear to a black window once loading is complete. If the window starts out 
maximized, double click on the top blue bar to resize it down. (When maximized, the editor 
simply stretches the image over the screen. This can confuse you when you try clicking around 
or zooming in and out, so it’s easiest to just use the default size.) 
 Under the File menu, select New. A dialog box will appear. 
 



 
 

The options are mostly self-explanatory, but just to be clear: 

• Name: The name of your map. The directory your map is saved to will be the 
same as this. 

• Description: A short description of your map. This is the same description you 
see when browsing the maps before hosting a game. 

• Use existing map: You can create a new map based off of another map. For 
instance, if you wanted to modify Sentry Point to remove the civilians, you could 
fill in the Map File field with the path to Sentry Point. This is effectively the 
same as opening a map and saving it with a different name. 

• Create new map: Starts a new, completely blank map. Selecting this will allow 
you to check and uncheck the Water field. 

• Width/Height: Size of the map in game units. A 5x5 km map is 256x256 game 
units wide. 

• Initial Elev.: How high the default terrain is. A good number is usually 64. Very 
low or very high initial elevations may cause problems later on when you are 
editing your heightmap. 

• Water: Enables or disables water. 



• Water Elev./Deep Elev./Abyss Elev.: The threshold values for rendering water. 
If the heightmap is below these values, the appropriate type of water will be 
rendered. It is important to keep these in mind if you are designing a map with 
water. Pick carefully, because they can’t be changed. (There is a way around this 
that will be covered later.) 

 Name your map whatever you would like. This guide will refer to it as Summer Duel, 
since we’re going to make a map similar to Winter Duel. You can leave the Description field 
blank if you’d like. Check the Create new map box. If you want to use water, keep the Water 
box checked; otherwise, uncheck it. Keep the map size at 256x256 and the initial elevation at 64. 
Click the Create button. 
 A new map will be created and displayed. Click the save button ( ) on the toolbar or go 
to File > Save. Saving your work is never a bad thing. You should do it as often as possible. The 
map editor is stable, but there are certain elements beyond your control. The last thing you want 
is for your power to flicker and erase three hours of hard work! Take a moment and get 
accustomed to the feel of the editor. Zooming works the same as in Supreme Commander. You 
can scroll with Middle Mouse Click + Drag and rotate with Alt + Middle Mouse Click + 
Drag. The current world coordinates of the mouse cursor are displayed in the lower right of the 
window. 
  
Molding the Terrain 

 Go to the View menu and ensure that Layers and Tool are checked. If not, check them 
now. Select the Elevation layer at the bottom of the Layers window: 
 



 
  

The Tool window should change if Elevation was not previously selected. It should look 
like this: 
 



 
 

At the top is choice of all available terrain brushes. The terrain will be raised up or down in the 
same shape as the brush. Blue means the terrain will be raised; red means the terrain will be 
lowered. The other options are: 

• Strength: How much your brush changes at a time. 

• Size: How large the brush is in world units. 

• Maximum: The maximum height allowed by the brush. If you are raising the 
terrain, a plateau will form at the height you specify here. Using a brush on terrain 
with a higher elevation than Maximum will cause the terrain to be lowered to 
Maximum. 



• Minimum: The minimum height allowed by the brush. It functions the same as 
Maximum, except that it acts as a lower boundary. 

 Before you set out to shape the map, it is very helpful to have an idea of what the final 
map should look like. As mentioned previously, this guide will create a map similar to Winter 
Duel. Go ahead and open up Winter Duel through File > Open. It can be found in the 
SCMP_013 directory. If the editor gives you a black screen, simply restart the program. If you 
encounter this problem frequently, you can start multiple instances of the map editor to switch 
between maps. Zoom around and pan the camera to get a feel for the landscape. 
 You should notice that the map is slightly bowl shaped. The terrain begins level where 
the players start, and gradually slopes downward into a small valley below. This is the first 
feature we are going to replicate. Smooth slopes such as this are set up by first creating a stair-
step pattern. Select the round1k brush from the Elevation Brush window. Set the Maximum 
field to 65 (remember: our initial elevation is 64, so this will create a step 1 unit high). Draw a 
line down the center of the map, slightly off to the left. Now set the Maximum field to 66 and 
repeat, placing a line slightly to the left of the first step. Repeat this all the way to the left edge of 
the map. The result should look similar to this: 
 

 
 

How closely together you space your steps will determine how steep the slope is. The leftmost 
side of this image has a height of 73; the center has a height of 64. 
 When designing the rest of the map, we need to keep in mind that the final product will 
be rotationally symmetrical. Although this takes some of the feel and personality away from the 
map, it does guarantee an even playing field, and that is an important consideration. 
Additionally, it will make texture and decal placement much easier, as we will see later. Since 
the map will be symmetrical, we only have to work on the left side of the map. 



 Changes on smooth terrain can be tricky, so we will keep the slope as a stair-step for 
now. Next we will add a cliff face protruding into the middle, similar to what Winter Duel has: 
 

 
 

 As you design cliffs, you will want to make sure you are actually creating cliffs. Go to 
View > Debug and click Slope. Green indicates that land is flat enough to construct buildings 
on. Red indicates that land is too steep for units to traverse. Colorless means that units can 
traverse that land, but it is too steep to build on. 

What next? Maps on Winter Duel frequently break into short stalemates in the center 
with massive defenses on opposing cliffs. Let’s add another cliff above the first to spice things 
up a bit. This cliff will shadow the one we just added, such that if an opponent can gain hold of 
it, they will gain a tactical stronghold against the enemy’s defenses. Terrain height is an 
important consideration when designing cliffs. A height difference of 2 is not passable by units, 
but such a low cliff is difficult to work with. Cliffs should typically be at least 4 units high. After 
some tinkering, the result should look similar to this: 
 



 
 

The next logical step is to do something with the lower left of the map. However, without 
visualizing the lower right, it’s difficult to make a good call. This is where Photoshop comes in. 
With the Elevation tool selected, click the property ( ) button on the top toolbar. Next click on 
Export Heightmap where your brush choices used to be. Save the .raw file in your map’s 
directory with a distinct name. Note that the editor will not prompt you if you try to overwrite an 
existing file. 

Open up Photoshop (or Paint Shop Pro) and load your .raw file. Important: .raw files do 
not contain any sort of default header information. It is up to you to supply the image properties. 
In our case the dimensions are one greater than the world dimensions. If this is not Photoshop’s 
guess, put in 257x257 as the image size. Make sure the image is loaded as a 16-bit, single 
channel image. The byte order is IBM PC. The dialog box should look similar to the following: 

 



 
 

Select the left half of the image using the marquee tool. An easy way to get exactly half is 
to choose Style: Fixed Size at the top toolbar. Set Height to 257 and Width to 127 or 128. With 
these properties set, click on the image. Click inside the selection box and drag it to the left of 
the image. The selection should snap to the edges. Press Ctrl + C to copy the selection, and then 
press Ctrl + V to paste it. Press Ctrl + A to select the entire image, and then press Ctrl + T to 
open up the transformation controls. At the top toolbar, set the rotation angle to 180.0° 
( ) and press Enter. You should now see a rotationally symmetrical image. If the 
rotated image did not move over to the right, select the arrow tool and move it there manually. 
Go to Layer > Flatten Image, then save the image as a .raw file in your map directory. Make 
sure the byte order is set to IBM PC! 
 Back in the Supreme Commander map editor, click on Import Heightmap. Load in the 
heightmap you just saved from Photoshop. Be careful with this feature, because it is not 
undoable. You should see the following: 
 



 
 

 The next step is to complete upper cliff we started. Do so on the bottom half so that it 
gets mirrored to the top next time we go through the Photoshop process. To get back to the 
brushes, click on the brush icon ( ) at the top toolbar or press B. After that, feel free to 
improvise a little. Experiment with the different brushes and settings to make something 
interesting, and keep in mind that your map needs to be fun to play. Focus your efforts on the left 
hand side of the map. When you are all finished, repeat the Photoshop mirroring procedure and 
load the new heightmap. Hopefully it will look something like this: 
 

 
 



 Things are shaping up nicely! Now that the basic outline of the map is established, we 
can smooth it out a bit. With the Elevation layer selected, click the blur icon ( ) at the top 
toolbar. You’ll notice a selection of four blur brushes. Blur128 and Unsharp128 are good general 
purpose blurring tools, while unsharp128_hard is great at getting into close areas. Select 
unsharp128_hard. Go through the stair-steps on the left-hand side of the map and blur them into 
a single smooth slope. Next, add some ramps to your cliffs by blurring the edges. Once again, 
repeat the Photoshop mirroring process and load the new heightmap. This is what the map looks 
like now: 
 

 
 

 We’re almost there! There are two things left to fix. The first is that there is a noticeable 
seam down the middle of the map. This is easily fixed by with the blur tool. Whether or not you 
use Photoshop to make the map perfectly symmetrical again is up to you. The second problem is 
a trickier one. If you zoom in on one of the cliffs, you’ll notice that it doesn’t look quite right. It 
has a noticeably jagged edge, and triangles are either missing or protruding out into the ground 
below. To fix this, go to the blur tool within the Elevation layer. Select blur128 as your brush. At 
the bottom you’ll notice a dropdown box. Choose the Impulse option. With a size that slightly 
extends to either side of the cliff face, run the brush along your cliffs. You can make them look 
much better with a bit of massaging. 
 



 
 

Congratulations, you’ve just completed your first heightmap! The cliffs in this case are 
not perfect and do show some popping. If you feel particularly ambitious, you can go through 
and add some small height variations to the map. Flat terrain is convenient for gameplay, but it 
looks rather dull and a little slope can dramatically improve the look of a map. 

 
Making it Playable 

 If you try to start your map from GPGNet right now you will be disappointed. Supreme 
Commander will not recognize the map in its current state. You must add players and starting 
locations before it works properly. 
 Go to the Armies layer in the Layer window. Click the leftmost “New” button ( ) twice 
to create ARMY_1 and ARMY_2. Next click on the Games layer in the Layer window. Click 
the Add button in the Configurations section. Click on the “New Config 1” label that appears. 
Click again so that it lets you type, and rename it to “standard”. Next click on the Add button in 
the Teams section. A team called “New Team 1” will appear. Drag the ARMY_1 and ARMY_2 
labels from Available Armies onto “New Team 1”. The final window should look like this: 
 



 
 

 The next step is to rename “New Team 1” to “FFA”. Unfortunately, this appears to be 
slightly buggy at the moment. We have to do it manually. First save your map. Next, open up the 
_scenario.lua file in your map’s directory with Notepad. Find the line that reads 
 

{ name = 'New Team 1', armies = {'ARMY_1','ARMY_2',} }, 
 

and change it to 
 

{ name = 'FFA', armies = {'ARMY_1','ARMY_2',} }, 
 

Don’t forget to save the file! Important: You must quit the map editor and restart it at this stage. 
If you don’t, “FFA” will get renamed back to “New Team 1” every time you save.  

The final step is to place the starting locations for each player. Click on the Markers 
layer in the Layer window. The Resource window will show you a selection of available 
markers. Drag a Blank Marker onto the map. It should look like this: 



 

 
 

In the list of markers currently on the map, click on “Blank Marker 00” and rename it to 
“ARMY_1”. As you might expect, this marker becomes the starting location for the first player. 
Place another marker and rename it to “ARMY_2” for the second player. 

Feel free to place the starting locations wherever you want. The grid view helps 
immensely to make sure starting locations are symmetrical. Turn it on by going to View > 
Debug > Grid. Green lines are 100 units apart; red lines are 10 units apart; white lines are 1 unit 
apart. If you want markers to snap to the grid, make sure you have AutoSnap to o-grid checked 
in the Options menu. Use snap-to-grid in conjunction with the mouse coordinates at the lower-
right of the window to make your starting locations symmetrical. Here is Summer Duel after 
placing the starting locations: 

 

 
 

Not much has changed, but it is now possibly to select the map and play on it! 
 
 



Texturing the Terrain 

 Summer Duel is awfully bland right now, and it doesn’t represent summer in the least. 
We need to add textures to the ground to give it some flavor. We will focus on the left hand side 
of the map just like before. Once that is complete, the right hand side will be created by rotating 
the textures in Photoshop. Texturing the map is relatively straightforward. Textures are placed in 
different layers called strata. Stratum 1 covers up the Lower Stratum, Stratum 2 covers up 
Stratum 1, Stratum 3 covers up Stratum 2, and Stratum 4 covers up Stratum 3. Strata 5-8 are 
unused. 

Let’s begin texturing by making the base texture a nice dirt. Select the Lower Stratum 
layer in the Layers window. Make sure the Resources window is open by checking Resources in 
the View menu. The Resource Browser should look like this: 

 

 
 
We are interested in the Stratum tab. Select the Desert tileset in the Tileset dropdown. Drag the 
picture of des_gravel01_albedo.dds from the Resource Browser onto the Albedo picture of the 
Strata Properties window. You should see a noticeable change in the look of your map. Next 
drag the picture of des_gravel_normal.dds from the Resource Browser onto the Normal picture 
in the Strata Properties window. If you are zoomed in closely enough you will see a second 
change. 
 Next go through and pick some textures you like for Strata 1-4. The normal part of a 
stratum is not required, but will improve a stratum’s look by imitating small variations in height. 



You can adjust the repeat rate of strata across the ground with the scrollbars in the Strata 
Properties window. The official maps tend to use relatively high repeat rates (low values in the 
number box). The normal textures are designed to have the same repeat as the color texture, 
although there is no particular reason they can’t be different. Many of the official maps use 
mismatching repeats to great effect. 
 Now comes the fun part: the actual painting! With a stratum selected (1, 2, 3, or 4), click 
the brush button on the top toolbar or press B. This interface should look familiar. Go nuts and 
paint the left half of your terrain into a work of art. Keep in mind what natural formations look 
like. For example, cliff faces will typically be rougher surfaces, and flat areas will be covered in 
grass. Don’t feel bad if it takes you a long time to get it right. This can be the most time 
consuming part of map creation. 
 If you like the symmetry of the terrain, you can use Photoshop to mirror each stratum. 
Click on the Export Mask button in the Strata Properties for each stratum. Save each to a .raw 
file with a distinct name and rotate them in Photoshop as you did for the heightmap. Then go 
through and reload them with Import Mask. Important: The terrain texture masks are half the 
size of your map. For a 256x256 map such as Summer Duel, they will be saved as a 128x128, 8-
bit texture. Make sure these settings are correct when you load the masks into Photoshop. 

Here’s the new and reborn Summer Duel: 
 

 
 
What a difference textures make! Note that unless you have a superhuman power for creating 
perfectly symmetrical images freehand, there will be a seam down the middle of your map. 
Minor touchups should correct the problem. Textures don’t impact gameplay, so absolutely 
perfect symmetry is not required. 
 Unfortunately, there was an unforeseen problem. Notice the tan strip along the bottom 
and right of the map. These portions of the map will only be covered by the Lower Stratum, so 



plan your map carefully if this bothers you. Later on we will see a nice trick to hide the ugly 
truth and make the strips invisible. 
 
Placing Resources 

 Now that the map is technically playable and has some visual appeal, it’s time to place 
some resources. A little care must be taken to ensure that the mass locations are fairly 
distributed. A commander should be able to build the four first mass extractors in the same 
amount of time from both sides of the map. If mass deposits are close enough to allow double-
adjacency, the same adjacency bonuses should be available to both sides. Mass deposits farther 
away should be the same distance from the starting location. For reference, a factory is 9 grid 
units wide and tall; power generators are 2.25 wide and tall. The commander build range is 10. 
 Placing resources is short and easy. Go back to the Markers layer in the Layer window. 
Drag a Mass marker and position it. Repeat for every mass deposit you want on the map. 
Hydrocarbon locations can be placed with the Hydrocarbon marker. See, easy! Here is a fully 
functional, enjoyable Summer Duel: 
 

 
 

 Here is an important note for future reference. The in-game preview for the map as it 
currently is will show the markers on it, just as they appear above. To get rid of them, check the 
Hide All Markers box in the Markers layer. Always save the map file with this box checked 
before you release your map to the public. That way the preview image will be clean. 
 



Placing Props 

 Every official map contains various props that add a great deal of flair to a map. These 
include trees and rocks that can be reclaimed for resources. This part is a little tedious, but it will 
be worth it in the long run. 
 Go to the Props layer in the Layer window. Next, click on the Props tab in the Resource 
Browser window. Select the Evergreen tileset in the Tileset dropdown and the trees category 
from the Category dropdown. Go ahead and drag one of the pictures onto your map. You should 
see appear, along with a blue circle. It looks like this: 
 

 
 

The pink sections allow you to manipulate the prop. Clicking on the E and dragging up and 
down will allow you to change the prop’s elevation. Clicking on the arrow allows you to rotate 
the prop. The S is used for resizing other items, but is unused for props. You can move the prop 
by clicking on it and dragging. Alternatively, holding R on the keyboard will allow you to rotate 
the prop without clicking; holding M on the keyboard will allow you to move the prop without 
clicking. 
 If we had to place each tree individually, we’d be stuck for days at this stage. Fortunately 
there is a way to place more than one at a time. Pick some trees you like and drag them into the 
Active props for automatic placement section of the Prop Edit window. You should see 
something like this: 
 



 
 

We are going to create a sort of “prop brush” defined by the settings here. What the three 
sliders do is self-explanatory. Slope falloff angles controls what types of slope your props will 
be placed on. Setting both Start and End will require the props to exist on perfectly flat terrain. 
A range of 0 to 20 is good for getting up close to cliffs without actually placing anything on a 
cliff. Once you are satisfied with your settings, click the Enable automatic placement mode 
checkbox. 

Moving the mouse over the map will display a circle defining your brush. Clicking will 
place props at the rate you set in Props to place per second. The actual rate may be lower 
because this is the number of props the editor attempts to place a second. If Min distance 
between props is set to a high number, the editor will not be able to fit them all within the brush. 
If you want to remove something from the brush, select it from the list and click the delete button 
( ). If you placed some props you didn’t mean to, you can either undo (Ctrl + Z) or uncheck 



the automatic placement mode box, drag a selection around the misplaced props, and press 
Delete on your keyboard 

Go through and place trees and rocks on the left-hand side of your map. To make them 
symmetrical, press Ctrl + A to select all props on the map. Press Ctrl + C followed by Ctrl + V 
to duplicate every prop. Without deselecting anything, check the Rotate about map center box. 
Type 180 into the Yaw box and click Set. Feel free to do this with multiple sets of props to give 
as natural a feel as possible. Here is Summer Duel with its new props: 

 

 
 

Lighting 

 The editor gives you full control of the world lighting Supreme Commander uses. To 
adjust the settings, go to the Lighting layer in the Layers window. The best way to get the hang 
of the settings is to experiment. You can create everything from a bright midday noon to a 
spooky dusk, so have fun! 
 
Adding Decals 

 The difference in visual quality between Low and High fidelity is staggering. Most of the 
difference is due to decals. Decals are individual textures placed onto the terrain. They can take 
different forms. Some are placed as images on the map, like the explosion scar from the initial 
commander warp. Other decals act as normal maps on the ground to give the appearance of 
roughness. Some of the official GPG maps contain hundreds of decals. If you are serious about 
your map, this part can be just as time consuming as the heightmap and textures—decal 
placement makes the difference between a pretty map and a gorgeous map. 
 Go to the Decals layer in the Layer window. Click on the Decals tab in the Resource 
Browser window. To add a decal, simply drag it from the Resource Browser window onto the 



map. The controls to manipulate decals work the same as for props. Holding S on your keyboard 
will allow you to resize the decal without clicking. Elevation controls are not available for 
decals. You can create symmetrical decals in the same way as you did props. To get to the Map 
centered rotation checkbox, click on the arrow at the top toolbar ( ). 
 If you drag a few decals and zoom around, you’ll notice that some of them fade out much 
too quickly. You can adjust this in the Decal Properties window. In the LOD Cutoff box, type in 
a higher number and click Set. You can also give a decal a minimum viewable distance with the 
Near LOD Cutoff box. Be very careful with these cutoffs. You want them high enough to be 
visible at normal zoom levels, but performance will be poor if you have a thousand decals with a 
cutoff of 10,000. With appropriate cutoffs there’s no excuse to hold back on decals, so make 
your map look as beautiful as possible! 

Have no fear if a decal gets buried under others and you can’t select it again. Holding 
down Ctrl while you click will allow you to cycle through multiple decals on top of each other. 
You can reorder the decal you have selected with the arrow buttons in the Decal Properties 
window. If you want to always see your decals in the editor, go to View > Force Decals. 
 
Basic Scripting 

 Map scripts allow you to add interactivity to your map. They can range from just five 
lines to hundreds or thousands of lines, as in some of the campaign missions. As cliché as it 
sounds, scripting really does open up a Pandora’s box of possibilities. This section serves only as 
a very basic introduction to map scripting with Lua. 
 Before we get to scripting, go to the Areas layer in the Layer window. Click on the 
“New” button ( ) to create an area entitled AREA_1. Click on the text under the Value column 
and change it to “1, 1, 255, 255”. The end result should look like this: 
 



 
 

Areas are always visible when you have the Areas layer selected. To view them with other 
layers, go to View > Debug > Areas.  
 Navigate to your map’s folder. You should see two .lua files: _save and _scenario. Create 
a third named _script by right clicking in the file area and going New > Text Document. Name 
the file <map name>_script.lua (for Summer Duel, it would be named summer duel_script.lua). 
Open up the blank file with Notepad and enter in the following text: 
 

local ScenarioUtils = import('/lua/ScenarioUtilities.lua') 
local ScenarioFramework = import('/lua/modules/ScenarioFramework.lua') 
 
function OnPopulate() 
    ScenarioUtils.InitializeArmies() 
    ScenarioFramework.SetPlayableArea('AREA_1', false) 
end 



The first two lines allow you to make use of other .lua files in your code. The function 
OnPopulate is called by the game engine when it is time to add entities to the map. The first line 
within this function tells the scenario to initialize the armies if they are not already done so by 
default. The second function sets the playable area of the map to the area we defined earlier. If 
you’ve played the campaign, this is essentially the same code used to expand the playing field 
after certain checkpoints. Save the file and go back to the editor. Go to Edit > Scenario and 
ensure that the Script path matches the file you created. Fix it if it does not. 

Remember those ugly tan strips along the edges of our map before? They’re gone now—
sort of. What we did is set the playable game area to just inside the edge of the strips. They still 
exist, but you can’t see them in the game anymore! 

Unfortunately, “real” scripting is far beyond the scope of this tutorial. In-depth coverage 
would take an entire book to complete. If you are serious about scripting, take a look at the 
campaign missions. There is a ton of example code there. You can also look through all of the 
unit code in the game by opening units.scd with Winrar. Finally, head on over to the official 
message boards and browse the Mod Developer Support forum. The developers of Supreme 
Commander are active posters there and they won’t hesitate to give you information! 
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